[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Seg faults with 2.4.22

> HI!
> I'm experiencing occasional seg faults with 2.4.22 while 2.4.21 worked
> without
> issues on the very same system (self-compiled BDB, SASL, OpenLDAP on RHEL
> 5
> with separate prefix) with the very same configuration. I can't provide a
> stack trace since data on this system is private.
> I suspect that something's wrong with slapo-allowed and deactivated it.
> Have
> to observe that a little bit more since the problems seem to be not
> deterministic. Were some API changes done in 2.4.22 which are not
> propagated
> to slapo-allowed?

slapo-allowed was modified between 2.4.21 and 2.4.22; support for
allowedChildClasses and allowedChildClassesEffective was added.

Looking at the diff, I don't see room for any (known) API/semantics
change.  Could you please backtrace the stack of next core dump?