[Date Prev][Date Next] [Chronological] [Thread] [Top]

2.4.19 (stable) - sync replication issue


I have TWO openldap servers (ServerA & ServerB) and recently i upgraded to 2.4.19.

Now when I add a record into ServerA, the new record appear inside both ServerA & ServerB, then 20 minutes later, the record will be deleted in both servers.

Here is the log that i discover:
Nov  4 23:33:48 srr200-001 slapd[28100]: nonpresent_callback: rid=002 nonpresent UUID e73bcd9c-5da0-102e-96f1-8d1c45da731c, dn uid=amyzjkang,ou=users,dc=ygmt,dc=com
Nov  4 23:33:48 srr200-001 slapd[28100]: syncrepl_del_nonpresent: rid=002 be_delete uid=amyzjkang,ou=users,dc=ygmt,dc=com (0)

Here is my conf file:

serverID 1

include        /etc/openldap/schema/core.schema
include        /etc/openldap/schema/cosine.schema
include        /etc/openldap/schema/inetorgperson.schema
include        /etc/openldap/schema/rfc2307bis.schema
include        /etc/openldap/schema/yast.schema
include        /etc/openldap/schema/samba3.schema
include        /etc/openldap/schema/dnszone.schema
include        /etc/openldap/schema/ygmt.schema

pidfile        /var/run/slapd/slapd.pid
argsfile    /var/run/slapd/slapd.args

# Load dynamic backend modules:
modulepath    /usr/lib/openldap/modules

access to attrs=SambaLMPassword,SambaNTPassword
    by dn="uid=administrator,ou=users,dc=ygmt,dc=com" write
    by * none

access to dn.base=""
        by * read

access to dn.base="cn=Subschema"
        by * read

access to attrs=userPassword,userPKCS12
        by self write
        by * auth

access to attrs=shadowLastChange
        by self write
        by * read

access to *
        by * read

loglevel 16384
TLSCertificateFile /etc/ssl/servercerts/servercert.pem
TLSCACertificatePath /etc/ssl/certs/
TLSCertificateKeyFile /etc/ssl/servercerts/serverkey.pem
database bdb
suffix "dc=ygmt,dc=com"
rootdn "uid=administrator,ou=users,dc=ygmt,dc=com"
rootpw "12345678pass"
directory /var/lib/ldap
checkpoint 1024 5
cachesize 10000
index objectClass,uidNumber,gidNumber eq
index member,mail eq,pres
index cn,displayname,uid,sn,givenname sub,eq,pres
index sambaSID eq
index sambaPrimaryGroupSID eq
index sambaDomainName eq
index entryCSN,entryUUID eq
index memberUid eq
index uniqueMember eq,pres
index sambaSIDList eq
index sambaGroupType eq

overlay memberof

syncrepl   rid=001
         retry="20 5 300 +"
mirrormode       on
overlay syncprov

Both of my server slapd.conf is identical except serverID and the provider=ldap ip address

The ldap syncrepl  was working previously.

Since the upgrade, i can't add any users if the syncrepl is turn on.

Now if i want to add a record, I have to manually turn off syncrepl. Then add the user into ServerA, Stop ServerB ldap and remove ldap DB, turn on syncrepl, restart & re sync.

How can i fix this issue?



Windows Live: Keep your friends up to date with what you do online.

Get Windows 7 for only $39.99-CDN College or University students only. This offer ends Jan 3-upgrade now!