[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: wiche DB-Version i need ?"* doesn't match environment version 0.22"

--On Monday, March 30, 2009 10:34 AM +0200 Sven Schoeppner <Schoeppner@biotec.uni-bremen.de> wrote:

i am a absulut beginner in Openldap.
I want to remove the db.log.
i got this message

mail2:/var/lib/ldap# db4.5_archive
db4.5_archive: Program version 4.5 doesn't match environment version 0.22
db4.5_archive: DB_ENV->open: DB_VERSION_MISMATCH: Database environment
version mismatch

Wehre can i get the Version version 0.22 .

Well, you don't need version 0.22, since there isn't such a thing. But you do need to see what version of BDB your slapd was linked against. If you didn't build it yourself, you can try running ldd on slapd to see what bdb library it linked against.



Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration