[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Installation Problem

>> Ladies and Gentlemen,
>> I have been working toward getting openldap installed for a few days
>> now,
>> and after all of the reading and searching I have done, I am still
>> receiving the dreaded Berkeley DB version mismatch error.
>> I have tried the installation with versions 4.2.52, 4.5.20 and 4.6.21 of
>> BerkeleyDB.
>> I have set CPPFLAGS and LDFLAGS as follows.
>> CPPFLAGS=-I/usr/local/BerkeleyDB4.5.20/include -I/usr/include
>> -I/usr/local/include
>> LDFLAGS=-L/usr/local/BerkeleyDB4.5.20/lib -L/usr/lib -L/usr/local/lib
>> Following is the output just before the error.
>> checking db.h usability... yes
>> checking db.h presence... yes
>> checking for db.h... yes
>> checking for Berkeley DB major version... 4
>> checking for Berkeley DB minor version... 5
>> checking for Berkeley DB link (-ldb45)... no
>> checking for Berkeley DB link (-ldb-45)... no
>> checking for Berkeley DB link (-ldb-4.5)... yes
>> checking for Berkeley DB version match... no
>> configure: error: Berkeley DB version mismatch
>> I am running FreeBSD 6.2.
>> Any suggestions would be greatly appreciated.
> Did you read the contents of config.log, to find out __why__ there' a
> version mismatch?  You also probably missed the point that the library
> doesn't just need to be linked, it also has to be loaded; so you didn't
> set LD_LIBRARY_PATH accordingly.
> p.
Thank you for your help.