[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Missing attributes

Hi Jochen,

Thanks that solved the problem. I changed "comment" to "description,
included the nis.schema in my slapd.conf as well as removing several
attributes that didn't work and now all is well.


On Dec 13, 2007 11:37 PM, Keutel, Jochen <mlists@keutel.de> wrote:
> Hello Michael,
> - gecos is an attribute of the object class posixAccount: See RFC2307.
> Just include nis.schema (delivered with OpenLDAP) in slapd.conf.
> - comment: I'm not sure. Probably it comes from the Microsoft ADS
> schema, see e.g. http://msdn2.microsoft.com/en-us/library/ms676199.aspx.
> The object class you'd need seems to be mailRecipient
> (http://msdn2.microsoft.com/en-us/library/ms682368.aspx).
> I'd recommend NOT to use 'comment' but something different (e.g.
> description or gecos) - so you don't have to reimplement parts of the
> ADS schema in OpenLDAP.
> Best regards,  Jochen.
> >> Hi list,
> >>
> >> I'm in the process of migrating a Red Hat OpenLDAP setup to SLED 10.
> >> I've got most things working however I'm trying to import an ldif
> >> which has a "gecos" and "comment" attribute but when I import the ldif
> >> I get these errors:
> >
> > You need to load whatever schema was creating the "comment" attribute.
> >
> > You need to fix your LDIF to include the objectClass that allows
> > "gecos". If that is compatible with inetOrgPerson.  Basically, you were
> > using an old version, likely with schemachecking off, and so someone
> > abused that in creating the data in your system, and you get to be the
> > one to fix it. ;)
> >
> > --Quanah