[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: slapd high CPU usage

--On Wednesday, October 17, 2007 4:07 AM +0200 Tony Earnshaw <tonni@hetnet.nl> wrote:

Experience (years of) plus own testing with RHEL5 says: Do Not Use Red
Hat's OpenLDAP, use Buchan Milnes'. My site's totally dependent on
OpenLDAP on multiple servers, has no problems. Red Hat's OL is
(presumably) patched to use the native BDB 4.3.29, whereas Buchan's has
its own discrete patched 4.2.52. At least one developer on this list has
written that the OL 2.3 source was deliberately written not to work with
BDB 43, go figure.

No, you are misreading. BDB 4.3 has been extremely flaky, so the OpenLDAP *configure script* has been made to abort if you try to build it against BDB 4.3. There's nothing specific in OpenLDAP's code that prevents it from working with BDB 4.3, it is all the problems in BDB 4.3 that prevents things from working. ;) Some distributions have *hacked* the OpenLDAP configure script so it will build against BDB 4.3, and there's nothing we can do about that.



Quanah Gibson-Mount
Principal Software Engineer
Zimbra, Inc
Zimbra ::  the leader in open source messaging and collaboration