[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Overlay "Constraint" in OpenLDAP 2.3?

On Wednesday 08 August 2007 12:24:56 Christian Marg wrote:
> Hello,
> according to
> http://www.openldap.org/its/index.cgi/Documentation?id=4844;#followup4
> the "constraint" Overlay was added to CVS April 29 2006.
> I was wondering why it isn't in current 2.3.x releases (after said date,
> of course), since I really could use the functionality provided by that
> plugin.

Either you need to build from CVS, or wait for 2.4.5, as:
1)It is 2.4.x only at present (note the subject of the ITS)
2)It did not make it to 2.4.4:

>From http://www.openldap.org/its/index.cgi/Documentation?id=4844;#followup5 :
Subject: Re: (ITS#4844) Missing 2.4 man pages and things marked 
     as "Experimental"

>>>> Just a quick to note that there are some overlays missing from
>>>> slapd.overlays.5
>>>> in 2.4.4alpha and actual man pages.
>>> Please enumerate them; some are intentionally not present because
>>> are not intended for real use.
>> * dyngroup has no man page, but is listed slapd.overlays.5
>> * slapo-valsort.5 isn't in slapd.overlays.5
>> * slapo-dds.5 isn't listed in slapd.overlays.5
>> * constraint.c has no docs or listed in slapd.overlays.5
> slapo-constraint.5 was added to CVS April 29 2006.

Ok, it wasn't in the 2.4.4alpha though.