[Date Prev][Date Next] [Chronological] [Thread] [Top]

Build error 2.3.35 on Debian

I'm getting this error when I run "make depend":

cd slapi; make -w depend
make[3]: Entering directory `/vol01/developer/openldap/openldap-2.3.35/servers/slapd/slapi'
../../../build/mkdep -l -d "." -c "cc" -m "-M" -I../../../include -I.. -I. -I../../../include -I./.. -I. plugin.c slapi_pblock.c slapi_utils.c printmsg.c slapi_ops.c slapi_dn.c slapi_ext.c slapi_overlay.c
plugin.c:32:18: ltdl.h: No such file or directory
make[3]: Leaving directory `/vol01/developer/openldap/openldap-2.3.35/servers/slapd/slapi'

Given the configure switches I'm using, I don't think it should even be attempting to build slapi:

./configure \
    --prefix=/opt/$OPENLDAP_VERSION \
    --localstatedir=/var/local/$OPENLDAP_VERSION \
    --sharedstatedir=/var/local/$OPENLDAP_VERSION/com \
    --enable-cleartext \
    --enable-crypt \
    --enable-lmpasswd \
    --enable-ldbm \
    --enable-syncprov \
    --enable-slurpd \
    --without-cyrus-sasl \

This error has also occurred with previous versions (at least 2.3.27, 2.3.31, 2.3.32) but it doesn't seem to cause any functional errors as far as I can tell. (unless it's somehow related to the syncrepl problems, but that seems unlikely)

Lesley Walker
Linux Systems Administrator
Opus International Consultants Ltd
Email lesley.walker@opus.co.nz
Tel +64 4 471 7002, Fax +64 4 473 3017
Level 9  Majestic Centre, 100 Willis Street, PO Box 12 343
Wellington, New Zealand