[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: problems with existing entries disappearing

Hash: RIPEMD160

I have the same problem. In my case the entry still exists but, the uid
is not longer in the index.

Until now I have no solution for the underlying problem, but you can
easily rebuild your index with slapreindex.

You can try to search by an other attribute than uid to verify that the
entry still exists.

Dieter Kluenter schrieb:
> Antonio Broughton <antonio@flerwin.net> writes:
>> Hi,
>> I am running OpenLDAP 2.2.13 on a CentOS 4.1 box (I am using the CentOS
>> ldap rpm)...
>> I have come across an issue, that I cannot seem to find the answer for
>> anywhere!...
>> The problem is that an entry has some how been removed from LDAP well,
>> according to phpLDAPadmin and also ldapsearch.
>> mytestentry _used to be_ in LDAP... it has now "gone?"
>> I am using the following ldapsearch string..
>> ldapsearch -x -b "dc=tree,dc=internal,dc=company,dc=co,dc=nz"
>> "uid=mytestentry"
> [...]
>> adding new entry
>> "uid=mytestentry,ou=Testing,dc=tree,dc=internal,dc=company,dc=co,dc=nz"
>> ldap_add: Already exists (68)
>> I have a few questions:
>> 1) Why would this entry be removed?
>> 2) Why when I try and add the entry, it says that it exists?
>> 3) Is there a way to fix it?
>> 4) Am I doing something wrong?
> The entry has not been removed, it seems that your access rules do not
> allow anonymous read on this object.
> -Dieter

- --
Hochschule der Medien
Studiengang Informationsdesign
Wolframstrasse 32

D-70191 Stuttgart
++49 (0)711 25706 114
Version: GnuPG v1.4.3 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org