[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: error with slapcat

--On Saturday, October 28, 2006 7:47 PM +0200 Mohamed AR <midomath@gmail.com> wrote:

I'm using BDB I need to know is this problem related to openldap or bdb and what cause of this problem I restored my data from backup and now it's working

If you wish continued help, please keep replies to the list.

Frankly, you supplied no information that helps one determine the cause of the problem. I understand you are using sleepycat BDB as your database software. Which OpenLDAP database backend are you using? See the "database XXX" part of slapd.conf. It would be one of ldbm, bdb, or hdb.

In any case, you are using ancient versions of the OpenLDAP software, with many known (and since fixed) bugs. 2.2.13 had many serious problems, including security holes. You really should be upgrade to at least 2.2.30.


-- Quanah Gibson-Mount Principal Software Developer ITS/Shared Application Services Stanford University GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html