[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Lost users after power outage

Thanks Howard! I will do this.

>>> Howard Chu <hyc@symas.com> 28/08/2006 2:05 p.m. >>>
max williams wrote:
> Hey all,
> Just had a power outage and after the servers had come back up there were about 5 users missing from my directory.
> So, I tried to add them again but get error saying they already exist, "ldap_add: Already exists (68)", even though I cannot see them in ldapsearch or even slapcat. To fix this I had to start with a clean DB and rebuild from an old ldif file. My slave servers all had the same problem too!
> I noticed this has been reported before:
> http://www.openldap.org/lists/openldap-software/200309/msg00507.html 
> I'm using version 2.2.23-5 on FC5 linux.
> Is there anything I can do to prevent this in the future?
Yes, upgrade to a supported release of OpenLDAP; 2.2.x is historical. 
2.3.27 is the current stable release.
Use back-bdb instead of back-ldbm.
Read the slapd-bdb(5) manpage. Read the BerkeleyDB documentation. Use 
Read the FAQ.

  -- Howard Chu
  Chief Architect, Symas Corp.  http://www.symas.com ( http://www.symas.com/ )
  Director, Highland Sun        http://highlandsun.com/hyc 
  OpenLDAP Core Team            http://www.openldap.org/project/ 

NOTICE: This message contains privileged and confidential
information intended only for the use of the addressee
named above. If you are not the intended recipient of
this message you are hereby notified that you must not
disseminate, copy or take any action in reliance on it.
If you have received this message in error please
notify Allied Telesis Labs Ltd immediately.
Any views expressed in this message are those of the
individual sender, except where the sender has the
authority to issue and specifically states them to
be the views of Allied Telesis Labs.