[Date Prev][Date Next] [Chronological] [Thread] [Top]

Should BerkeleyDB 4.3 be used along with latest OpenLDAP 2.3 series?


Recently I have received some claims that says OpenLDAP 2.3.x (latest
stable) does not work well with OpenLDAP 2.3 series, and it is better to
use BDB 4.2.x instead of 4.3.x to archive better stability and/or
performance.  After some Google search against the mailing list archive,
the only clue I can find to support the claim is in mid-2005.  Moreover,
the FAQ did not say that 4.3 is not encouraged[1] (nor encouraged,
though), so this makes me confused.

Is the situation still hold true?  Because I maintained the OpenLDAP
port for FreeBSD I think it would be better if we get a stable
out-of-the-box installation, and because I did not encountered a single
problem which looks like bdb related, I would like to hear some
"official" information from developers, and make a change if necessary.

Thanks in advance!

Xin LI <delphij delphij net>    http://www.delphij.net/

Attachment: signature.asc
Description: =?UTF-8?Q?=E8=BF=99=E6=98=AF=E4=BF=A1=E4=BB=B6=E7=9A=84=E6=95=B0?= =?UTF-8?Q?=E5=AD=97=E7=AD=BE=E5=90=8D=E9=83=A8=E5=88=86?=