[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: libldap-2.2.so.7 - RHEL4 library problem

On Wednesday 22 March 2006 17:13, Yuugy wrote:
> I'm attempting to build OpenLDAP 2.3.20 and running
> into problems with library conflicts with
> libldap-2.2.so.7 and
> libldap2.3_0-2.3.20-1.  If I uninstall the Openldap
> 2.2.13 rpm it would remove the libldap-2.2.so.7.  I'd
> tried using Buchan Milne's Mandriva rpms from post
> "http://www.openldap.org/lists/openldap-software/200602/msg00379.html";
> but I get "error: Failed dependencies:
>         openldap2.3 >= 2.1.25-4mdk is needed by
> libldap2.3_0-2.3.20-1.rhel4es.i386" when attempting to
> install his libldap2.3_0-2.3.20-1.rhel4es.i386.rpm.

1)Use a real package manager (yum, smart), I think I have both old and new 
yum-style headers available, and run 'yum install openldap2.3-servers' or 
'smart install openldap2.3-servers'
2)Start by installing both packages libldap2.3_0 and openldap2.3 
simultaneously, eg "rpm -Uvh libldap2.3_0-2.3.20-1.rhel4es.i386.rpm 

> I 
> basically want to keep libldap-2.2.so.7 but want to be
> able to install OpenLDAP 2.3.20 with the new
> libldap2.3 library.

You can, but the library (libldap2.3_0) really should have a configuration 
file available (which is about the only contents of the openldap2.3 package)


Buchan Milne
ISP Systems Specialist

Attachment: pgpsLjETyLqp0.pgp
Description: PGP signature