[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem with transfer data from 2.0.x to 2.2.y

At 03:50 AM 2/10/2006, Marian Hromiak wrote:
>I have problem with transfer data from 2.0.x to 2.2.y. I found that this
>is, because version 2.2 have more restriction for data as previous
>version, but I'm absolute newbie and I don't understand schemas and so on.

I note that LDAP/X.500 schema model is not really specific
to OpenLDAP Software.   In all versions of OpenLDAP Software,
the user was expected to provide data that conformed to the
LDAP/X.500 schema models.  It's just, as you note, later
versions of server perform more schema checks and hence
report more problems and reject more ill data.  That is,
the data was just as ill before as it is now.

To obtain a better understanding of the LDAP/X.500 models,
I suggest you read a good book on the subject and, for
any general LDAP/X.500 schema question you might have,
use a general LDAP/X.500 mailing list to seek answers.
(See http://www.openldap.org/lists/ for suggestions).

In attempting to load the following ill data, you likely
got a number of errors.  These are discussed in the
FAQ at http://www.openldap.org/faq/index.cgi?file=53.
Note that the errors and these FAQ answers generally
assume the reader has a basic understanding of the
LDAP/X.500 models.  If you don't, well, see above.

>What I must change when I want properly import
>this data into openldap 2.2.x?

Fix the schema errors.   I note that you consider
asking a general LDAP list as to what schema errors
are in your data and how to resolve them.  As indicated
above, this question is not OpenLDAP specific and,
hence, when doing so, I suggest you phrase it as