[Date Prev][Date Next] [Chronological] [Thread] [Top]

AW: LDAP 2.3.17 won't compile on Solaris 8 -- Openssl problem

Thanks for the replies.

I didn't know about the 2.3.17 Solaris bug, I'll give .19 a spin for sure. However, the problem -- and this is actually a little embarrassing -- turned out to be my LD_LIBRARY_PATH, which needed /usr/local/ssl/lib in there.

That tip about the shared SSL libraries I think only applies to 0.9.8a. I read somewhere that by default .8a does not compile shared libraries, although why that should be the case is a mystery to me.

Anyway, there's a day of work ahead of me so...


-----Ursprüngliche Nachricht-----
Von: Quanah Gibson-Mount [mailto:quanah@stanford.edu] 
Gesendet: Montag, 6. Februar 2006 19:03
An: Russell Toby (VE I-XAE); OpenLDAP-software@OpenLDAP.org
Betreff: Re: LDAP 2.3.17 won't compile on Solaris 8 -- Openssl problem

--On Monday, February 06, 2006 7:43 AM +0100 Toby.Russell@vattenfall.de 

> Hello all,
> After googling on the problem of configure not finding ssl.h, I did 
> the following and got a little further (OpenSSL 0.9.7h):

I'll note that a long-standing issue with a Solaris kernel bug finally got 
a workaround in 2.3.19, so spending your time building 2.3.17 for Solaris 
is kind of silly.  I suggest downloading 2.3.19.


Quanah Gibson-Mount
Principal Software Developer
ITS/Shared Application Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html