[Date Prev][Date Next] [Chronological] [Thread] [Top]

LDAP 2.3.17 won't compile on Solaris 8 -- Openssl problem

Hello all,

After googling on the problem of configure not finding ssl.h, I did the following and got a little further (OpenSSL 0.9.7h):

export CC=gcc
export CPPFLAGS="-I/usr/local/ssl/include"
export LDFALGS="-L/usr/local/ssl/lib"
./configure --enable-crypt --disable-cleartext --enable-denyop --enable-dyngroup --enable-dynlist --enable-ppolicy --with-cyrus-sasl --with-tls --enable-spasswd --enable-rlookups --with-ssl=/usr/local/ssl

However, ssl is still a problem, and I can now find no one who has had a similar experience. Here is the output from configure:

checking openssl/ssl.h usability... yes
checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
checking for SSL_library_init in -lssl... no
checking for ssl3_accept in -lssl... no
checking OpenSSL library version (CRL checking capability)... yes
configure: error: Could not locate TLS/SSL package

Does this error originate in how OpenSSL was compiled? I got exactly the same result on a Solaris 10 box too, by the way, same ssl version.


Vattenfall Europe Information Services GmbH
Datacentre Systemservice         
Überseering 12
22297 Hamburg
Rohrdamm 7
13629 Berlin
fon +49 (0) 30 60005 - 4533
fax +49 (0) 30 60005 - 4549
E-Mail   mailto:toby.russell@vattenfall.de
Internet http://www.vattenfall.de/is