[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: LDAPv2 doesn't work in 2.3.17

Quoting Quanah Gibson-Mount <quanah@symas.com>:

--On Sunday, January 15, 2006 6:19 PM +0100 Alberto Brosich <brosich@univ.trieste.it> wrote:

There's any reason why LDAPv2 doesn't work in release 2.3.17?
I'm migrating from 2.2.30.

I have the following option in global section of slapd.conf

allow bind_v2

Thanks in advance

It works just fine for me:

# ldapsearch -x -h localhost -P 2 -b "dc=symas,dc=com" uid=user.110
# extended LDIF
# LDAPv2
# base <dc=symas,dc=com> with scope subtree
# filter: uid=user.110
# requesting: ALL

# user.110, peons, symas.com
dn: uid=user.110,ou=peons,dc=symas,dc=com


Ok! With ldapsearch works for me too. My apologies. I tried with phpldapadmin and other tools.

The question now is:

Why supportedLDAPVersion attribute of rootDSE has only value 3?
With the same tool on 2.2 it has both values (2 and 3).

# ldapsearch -b "" -s base '+extensibleObject' | grep supportedLDAPVersion
supportedLDAPVersion: 3

Alberto Brosich

---------------------------------------------------------------- This message was sent using IMP, the Internet Messaging Program.