[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: LDAP proxy with features

> -----Original Message-----
> From: Pierangelo Masarati [mailto:ando@sys-net.it] 
> Sent: Monday, December 05, 2005 11:06
> To: Pratt, Benjamin E.
> Cc: openldap-software@openldap.org
> Subject: RE: LDAP proxy with features
> > The only configuration file I ended up changing was 
> slapd.conf. After I
> > changed "map attribute" to read "rwm-map attribute" I was 
> able to run
> > slaptest with no errors
> but does it work?   I don't think slapd-ldap(5) recognizes "map" any
> longer.  mapping support has been moved to slapo-rwm(5) in 
> OpenLDAP 2.3.
> > whether I was pointing at a backend server via
> > ldap or ldaps.
> mapping and ldaps should be orthogonal.  ldaps used by a 
> client requires
> appropriate client configuration of TLS, but I don't think 
> slaptest(8) is
> going to complain if this configuration is missing or not 
> appropriate.  I
> suggest you check if and how slapd refuses to start and 
> increase log level
> in order to determine the reason of failure.
> p.
> -- 
> Pierangelo Masarati
> mailto:pierangelo.masarati@sys-net.it
I managed to get attribute mapping working from your first e-mail, thank

The part that is confusing me about LDAPS is that in previous versions I
never touched the ldap.conf file. I just had to configure the slapd.conf
file. The ldap.conf file was never touched.

The proxy is making a call out to the backend server but something's
getting hung. Yes, the backend server is running LDAPS I just can't
figure out where the process is hanging.