[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: LDAP 2.3.12 is not working!!!

Regarding the DB_PRIVATE error people are seeing, please see the following quote about what I said before (different version, but same issue, no doubt):

I said:
> I, too, experienced the same problem and discovered it to be that
> slapd was getting linked against libdb-4.2.a and not libdb-4.2.so.
> hyc (Howard Chu) told me it was a bug in libtool.

> Check out ITS#3977, apply Howard's diff (from response #11).
> Re-run configure and rebuild, all should be well.

Quanah Gibson-Mount wrote:

--On Sunday, December 04, 2005 3:13 PM +0200 Amir Saad <Amir.Saad@bibalex.org> wrote:

i tried to use 4.3 (i tested it with Openldap 2.3.11 and it worked), but it didn't start too!

Unless you figured out how to hack configure in OpenLDAP 2.3.12, which I have my doubts about, you couldn't have compiled it against BDB 4.4 anyway. At a guess, OpenLDAP configure is picking up a BDB version other than what you built. You probably should read the pages on linking against the version of BDB that you want:


And I will note, BDB 4.2.52 + patches has been rock stable for me for a few years now. I've yet to see any benefit from moving to a different version of BDB.




may all be of interest to you.


Quanah Gibson-Mount
Principal Software Developer
ITSS/Shared Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html