[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Some syncrepl questions

Andreas Grabner wrote:

i plan to upgrade my master server to 2.3.11. I have some slave servers
version > 2.2.23 which get its updates via slurpd through slow (128kb/s)
unreliable WAN links.

Some questions apper:
Does it make sense to change to syncrepl?

Plain syncrepl uses more network bandwidth than slurpd. Delta syncrepl may be a better choice here.

Can i config syncrepl in cn=config?


How should the .ldif look?

See the Admin Guide, section http://www.openldap.org/doc/admin23/slapdconf2.html

Are theree any issues with 2.3 to 2.2 replication?

You need at least version 2.2.24 to accept replication updates from a 2.3 master. You need at least version 2.3.12 to accept replication updates from any previous release.

 -- Howard Chu
 Chief Architect, Symas Corp.  http://www.symas.com
 Director, Highland Sun        http://highlandsun.com/hyc
 OpenLDAP Core Team            http://www.openldap.org/project/