[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: installation problems

When running OpenLDAP config script it tells me:

"Configure: error: could not locate TLS/SSL package"

However, when its "checking for /openssl/ssl.h" it gives a "yes" response.
All below it are no.  Any ideas?


Dave Henderson

Distributed Computer Systems Analyst
Florida Department of Corrections
Phone: 407.207.7391            Suncom: 343.7391

-----Original Message-----
From: Samuel Tran [mailto:stran@amnh.org] 
Sent: Wednesday, October 19, 2005 10:02 AM
To: Henderson, David
Cc: openldap
Subject: RE: installation problems

On Wed, 2005-10-19 at 08:49 -0400, Henderson.David@mail.dc.state.fl.us
> Sam, 
>         What other software did you install to get OpenLDAP installed
> on the system.  Here are the steps and software and version of
> everything I have done.
> OpenSSL (0.9.8) 
> --------------------------- 
> ./config shared zlib-dynamic 
> make 
> make test 
> make install
> Berkeley DB ( 
> --------------------------- 
> patch -i patch.4.2.52.x 
> cd build_unix 
> ../dist/configure 
> make 
> make install
> Cyrus SASL (2.1.21) 
> --------------------------- 
> ./configure --with-openssl=/usr/local/ssl 
> make 
> make install 
> ln -s /usr/local/lib/sasl2 /usr/lib/sasl2
> OpenLDAP (2.2.26) 
> --------------------------- 
> env
.2/lib:/usr/local/ssl/lib" LDFLAGS="-L/usr/local/lib -L/usr/local/lib/sasl2
-L/usr/local/BerkeleyDB.4.2/lib -L/usr/local/ssl/lib -R/usr/local/lib
-R/usr/local/lib/sasl2 -R/usr/local/BerkeleyDB.4.2/lib -R/usr/local/ssl/lib"
CPPFLAGS="-I/usr/local/include -I/usr/local/include/sasl
-I/usr/local/BerkeleyDB.4.2/include -I/usr/local/ssl/include" ./configure
--enable-bdb --with-cyrus-sasl --enable-spasswd --enable-slurpd --with-tls

I installed the exact same software: OpenSSL, BDB and Cyrus SASL using
the same version and almost the same configure options.

What error message do you get now?