[Date Prev][Date Next] [Chronological] [Thread] [Top]

Workaround for: static ppolicy overlay init (ITS#3137) problem in slapd

I am having this problem (http://www.openldap.org/lists/openldap-bugs/200405/msg00032.html) in 2.3.7 and 2.3.9 and am trying to figure out how to work around it.
I've noticed that building the package with certain combinations of configure options (none, for instance) builds two versions of slapd, one that exhibits this problem and another that does not show the problem.
For example, when I do ./configure with no options, /usr/sbin/slapd has the problem, /usr/local/libexec/slapd does not.
I don't know what the differences in the two versions are.  Can anyone enlighten me there?
The other thing I found is that when I ./configure with the options --prefix and/or --sysconfdir, the libexec slapd does not get built.  Does anyone know why this should be the case?
Thanks for any help,

 Yahoo! Music Unlimited - Access over 1 million songs. Try it free.