[Date Prev][Date Next] [Chronological] [Thread] [Top]

Help -- replication broken with 2.1 -> 2.2 Master upgrade!

We have upgraded our LDAP master to CentOS 4.1 (RHEL 4 derivative), which includes openLDAP 2.2.13, and replication broke. The config file is the same, with just some changes in the schema inclusion (the old DB was dumped and reloaded without errors). The problem is that the master is not writing the replogfile!

The relevant section of my slapd.conf:

replogfile      /etc/openldap/replication.log
replica uri=ldap://ldap-slave.cs.umass.edu:389
        bindmethod=simple credentials=secret starttls=yes

I stopped slurpd, successfully wrote an update to the master, and the replication.log is empty. This configuration worked fine under RHL 9 with OpenLDAP 2.1. I looked through the OpenLDAP 2.2 docs, the replcation slapd.conf syntax seems to be the same; but replication log remains empty, and its mtime unchanged, no matter what updates I write to the master!

	Any ideas?

P.S. We did change from ldbm to bdb in upgrading the server, but this should have no impact on the replication log writing, should it? Also, our slave has been OpenLDAP 2.2.13 for a while, and working fine. Again, this shouldn't have any impact on replogfile issue on the master...

|  Victor  Danilchenko  | Catch a man a fish, and you can sell it to him; |
| danilche@cs.umass.edu | teach him to fish, and you'll ruin a wonderful  |
|   CSCF   |   5-4231   | business opportunity.                           |