[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: upgrade problems, can't query

--On Wednesday, July 06, 2005 12:22 AM +1000 Tyler Retzlaff <rtr@softelsystems.com.au> wrote:

After upgrading from openldap-2.0.27 to openldap-2.1.29 I can no  longer
(even anonymously) against my directory.  Basically I get:

Out of curiosity, why did you go from one deprecated release to another? I'll note that 2.2.26 is the current stable release, and 2.3.4 is the current release. This upgrade still leaves you two major releases behind. 2.1.29 wasn't even the last 2.1 release (2.1.30 was).

The configuration is identical, I haven't changed a thing.  The data  is
the same, I did
however back it up before upgrading.

There were changes to the basic defaults between 2.0 and 2.1. For example, if your client is making an LDAP v2 bind, you must specifically allow that in the configuration file (allow bind_v2). You may want to turn up the debugging levels and see exactly why you are getting the errors that you are (slapd -d -1 is useful for this).


Quanah Gibson-Mount
Principal Software Developer
ITSS/Shared Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html

"These censorship operations against schools and libraries are stronger
than ever in the present religio-political climate. They often focus on
fantasy and sf books, which foster that deadly enemy to bigotry and blind
faith, the imagination." -- Ursula K. Le Guin