[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: trouble in installing openldap: configure: error: Could not locate TLS/SSL package

--On Thursday, June 30, 2005 1:34 PM -0700 Yoginee Bhagwat <ybhagwat@micromuse.com> wrote:

Hi ,

I am trying to install openldap2.2.26 on linux. I have installed
openssl0.9.8-beta6 and BerkeleyDB4.3

Here is how I am running config :

env CPPFLAGS="-I/usr/local/ssl/include -I/usr/local/ssl/include/openssl
-I/usr/kerberos/include -I/usr/local/BerkeleyDB.4.3/include"
LDFLAGS="-R/usr/local/ssl/lib -L/usr/local/ssl/lib
-R/usr/local/BerkeleyDB.4.3/lib -L/usr/local/BerkeleyDB.4.3/lib"
./configure --with-tls --enable-slurpd

I suggest trying openssl-0.9.7. You are in unknown waters by trying openssl0.9.8. I would also note the recommended BDB version for the OpenLDAP 2.2 tree is BDB 4.2.52 (+ patches).


Quanah Gibson-Mount
Principal Software Developer
ITSS/Shared Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html

"These censorship operations against schools and libraries are stronger
than ever in the present religio-political climate. They often focus on
fantasy and sf books, which foster that deadly enemy to bigotry and blind
faith, the imagination." -- Ursula K. Le Guin