[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Berkeley DB version incompatible

--On Friday, March 11, 2005 6:34 PM +0100 Fernando RamÃrez SÃnchez <fernando.ramirez@horus.es> wrote:

Hi all,

I am installing OpenLDAP over Red Hat Enterprise Server 3 and I get the
next output when I execute the configure command

checking for db.h... yes
checking for Berkeley DB link (default)... no
checking for Berkeley DB link (-ldb43)... no
checking for Berkeley DB link (-ldb-43)... no
checking for Berkeley DB link (-ldb-4.3)... yes
checking for Berkeley DB version match... yes
checking for Berkeley DB thread support... no
checking Berkeley DB version for BDB backend... no
configure: error: BDB/HDB: BerkeleyDB version incompatible

I have installed  Berkeley 4.3 in /usr/local/BerkeleyDB.4.3 but the error
goes on.

Any ideas?

Search the list archives, or read the OpenLDAP FAQ, as this question has been asked and answered several hundred times.

I'll note that the README for OpenLDAP 2.2.23 saying BDB 4.3 is required is incorrect, and your system will be better off using BDB 4.2.52 + patches.


Quanah Gibson-Mount
Principal Software Developer
ITSS/Shared Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html

"These censorship operations against schools and libraries are stronger
than ever in the present religio-political climate. They often focus on
fantasy and sf books, which foster that deadly enemy to bigotry and blind
faith, the imagination." -- Ursula K. Le Guin