[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: R: slapdd - not enough space

--On Wednesday, February 16, 2005 1:54 PM -0500 Samuel Tran <stran@amnh.org> wrote:


Do you mean that BDB 4.3.27 is not suitable for production when used
with OpenLDAP?

I wouldn't use it on my systems, but that is my opinion.

As one of my esteemed colleagues noted when we were discussing BDB 4.3... look at how many releases it took for BDB 4.2 before it became stable (52) and that still required a few patches.

I've simply found the way in which BDB 4.3 handles its logs and allocates memory to routinely be problematic. Very preliminary testing of performance of BDB 4.3 I've done hasn't found it to be any faster than BDB 4.2, and in some cases, it appears to be slightly slower. I honestly see no reason to upgrade to BDB 4.3 unless you need the transactions bits, and even then you could apply the transactions patches I have posted to my website for BDB 4.2 & OpenLDAP instead.


Quanah Gibson-Mount
Principal Software Developer
ITSS/Shared Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html

"These censorship operations against schools and libraries are stronger
than ever in the present religio-political climate. They often focus on
fantasy and sf books, which foster that deadly enemy to bigotry and blind
faith, the imagination." -- Ursula K. Le Guin