[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem installing openldap 2.2.23

Hi Roberto,

On Tue, 2005-02-15 at 07:23, Roberto Balducci wrote:
> Hi all, 
> i'm trying to install new release of Berkeley DB and Openldap: Bdb 4.3.27 and Openldap 2.2.23.
> Berkeley DB seems to be installed correctly, but when i try to start installation of openldap, the configure command gives:
> "checking for Berkeley DB version match... 173190:./conftest: /sbin/loader: Fatal Error: Cannot map library libdb-4.3.so"
> I'm working on a Tru64 5.1A.
> Environment settings:
> CC=cc
> CFLAGS=-O pthread
> CPPFLAGS="-DHAVE_GETADDRINFO -I/usr/local/include 
> -l/usr/local/BerkeleyDB.4.3/include
> LDFLAGS="-L/usr/local/BerkeleyDB.4.3/lib"

I don't know if it is a typo but CPPFLAGS should be:

CPPFLAGS="-DHAVE_GETADDRINFO -I/usr/local/include -I/usr/local/BerkeleyDB.4.3/include"

You may want to install OpenLDAP with TLS/SSL support as well.

Hope this helps.


Attachment: signature.asc
Description: This is a digitally signed message part