[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: installing overlays?

Hash: SHA1

Is this perhaps the wrong list for this question? (openldap-dev better?)

I figured it would be of interest to users to know how to enable
password policy enforcement on openldap - it would for me atleast  :)

on 31-01-2005 16:56 Klavs Klavsen wrote:
| Hi guys,
| I read about the interesting ppolicy overlay and that it should work for
| openldap 2.2.19 (if I use v1.28).
| I want to compile it, and have dl'ed ppolicy.c (from
| servers/slapd/overlays - retrieved via cvsweb in v1.28) and when I then
| edit the Makefile - so all entries for pcache also exists for ppolicy,
| and run make and then make ppolicy.la - it builds a ppolicy.la file just
| fine.
| When I try to load that, and start slapd I get this however (-d9):
| slap_sasl_init: initialized!
| |>> dnNormalize: <cn=Subschema>
| => ldap_bv2dn(cn=Subschema,0)
| ldap_err2string
| <= ldap_bv2dn(cn=Subschema)=0 Success
| => ldap_dn2bv(272)
| ldap_err2string
| <= ldap_dn2bv(cn=subschema)=0 Success
| <<< dnNormalize: <cn=subschema>
| lt_dlopenext failed: (ppolicy.la) Cannot open
| "/usr/local/lib/openldap/ppolicy-2.2.so.7"
| /usr/local/etc/openldap/slapd.conf: line 33: failed to load or
| initialize module ppolicy.la
| I used these options to load ppolicy
| http://www.symas.com/techtips/introtooverlays.html
| I would very much appreciate any hints as to how I would go about
| building that .so file it says it needs..
| p.s. I'm running on freebsd-5.3.

- --
Klavs Klavsen, GSEC - kl@vsen.dk - http://www.vsen.dk
PGP: 7E063C62/2873 188C 968E 600D D8F8  B8DA 3D3A 0B79 7E06 3C62

"Those who do not understand Unix are condemned to reinvent it, poorly."
~  --Henry Spencer
Version: GnuPG v1.2.6 (GNU/Linux)