[Date Prev][Date Next] [Chronological] [Thread] [Top]

db-4.3.27 version mismatch with OL-2.2.22


I have just installed BerkeleyDB-4.3.27 and OpenLDAP-2.2.22.
When running configure I get an error '-ldb-4.3 version mismatch',
following an excerpt from configure.log

configure:16137: cc -c -g -O2 -I/usr/local/BerkeleyDB.4.3/include conftest.c 1>&5
configure:18061: checking for db.h
configure:18071: cc -E -I/usr/local/BerkeleyDB.4.3/include conftest.c >/dev/null 2>conftest.out
configure:18101: checking for Berkeley DB link (default)
configure:18158: cc -o conftest -g -O2 -I/usr/local/BerkeleyDB.4.3/include -L/usr/local/BerkeleyDB.4.3/lib conftest.c   -pthread -lresolv  1>&5
/tmp/cciJ8VPp.o(.text+0x17): In function `main':
/work/openldap-2.2.22/configure:18134: undefined reference to `db_version'
/tmp/cciJ8VPp.o(.text+0x49):/work/openldap-2.2.22/configure:18148: undefined reference to `db_env_create'
collect2: ld returned 1 exit status
configure: failed program was:
#line 18111 "configure"
#include "confdefs.h"
configure:18344: checking for Berkeley DB link (-ldb-4.3)
configure:18401: cc -o conftest -g -O2 -I/usr/local/BerkeleyDB.4.3/include -L/usr/local/BerkeleyDB.4.3/lib conftest.c -ldb-4.3  -pthread -lresolv  1>&5
configure:19885: checking for Berkeley DB version match
configure:19933: cc -o conftest -g -O2 -I/usr/local/BerkeleyDB.4.3/include -L/usr/local/BerkeleyDB.4.3/lib conftest.c -ldb-4.3  -pthread -lresolv  1>&5
configure: failed program was:
#line 19900 "configure"
#include "confdefs.h"

Any hints?


Dieter Klünter | Systemberatung
GPG Key ID:01443B53