[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Problem during installation

I've already mentioned that problem a few weeks ago ... here's a short workaround, but below I repost my question which had'nt been answered ...
short solution:

export LD_LIBRARY_PATH=path_of_bdb_libs

My previous post:


I'am building my own relocatable RPM package of openldap 2.2.15, and I noticed that the configure script couldn't anymore check the BDB package version . Indeed my package (as Redhat/Fedora packages do ) include it's own version on BDB (4.2.52) to keep beeing system indepedent about BDB version.
Everything worked fined before (in 2.2.14 at least !) but since 2.2.15 I concluded that the conftest binary needs to be told where is the embeded BDB libraries, in short I added LD_LIBRARY_PATH=../db-4.2.52/build-rpm/.libs/ before running "test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null" at line 19291 in configure script .
If not, configure ended with :
configure: error: Berkeley DB version mismatch

What changes between 2.2.14 and 2.2.15 causes this to happen ? is it normal or there's an error in 2.2.15 configure script ?
Here's the patch I applied:

$ cat /usr/src/redhat/SOURCES/openldap-2.2.15-configure.patch
diff -ur openldap-2.2.15.old/configure openldap-2.2.15/configure
--- openldap-2.2.15.old/configure 2004-07-27 18:33:12.000000000 +0200
+++ openldap-2.2.15/configure 2004-08-05 15:32:28.371610872 +0200
@@ -19288,10 +19288,14 @@
return 0;
+export LD_LIBRARY_PATH=../db-4.2.52/build-rpm/.libs/
+echo jehan $LD_LIBRARY_PATH 1>&5
if { (eval echo configure:19292: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
+echo "jehan then" >&5
+echo "jehan else" >&5
echo "configure: failed program was:" >&5
cat conftest.$ac_ext >&5
rm -fr conftest*

With that patch it now builds correclty and my relocatable package works fine ( I will send an other mail about the ditribution of that package ...)


Olivier PAYRE wrote:


I'm trying to install OpenLDAP (the last version ! 2.4) on my computer
(Mandrake 10.0). BerkeleyDB 4.2.52 is installed in /usr/local/
My command to configure OpenLDAP (before make) is :
env CPPFLAGS="-I/usr/local/ssl/include
-I/usr/local/BerkeleyDB.4.2/include " LDFLAGS="-L/usr/local/ssl/lib
-L/usr/local/BerkeleyDB.4.2/lib " ./configure --enable-cleartext
--enable-spasswd --enable-rewrite --enable-ldap --enable-meta
--enable-passwd –enable-slurpd

and the message is :

	configure: error: Berkeley DB version mismatch
I don't know what to do ...

PAYRE Olivier
CSIE - France