[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: SASL Authentication

Am Montag, 20. September 2004 23:53 schrieb Ammar T. Al-Sayegh:

> > Not sure SASL_MECH works properly (there was an issue
> > reported with it some time ago).  I suggest that for
> > those not wanting to support GSSAPI authentication,
> > that they configure Cyrus SASL without GSSAPI
> > support
> That's my configure command:
> configure --with-ldap --prefix=/usr --disable-krb4 --disable-gssapi
> But strangely enough, it still insists on using GSSAPI!
> Here is an example:

Cyrus-SASL scans the PLugin-Directory (/usr/lib/sasl2/) for it's libs. It is 
senseless to rebuild Cyrus-SASL without one Plugin if it is already in the 

> The above configure command will not remove GSSAPI?
> How else can I remove this plugin? I couldn't find
> another reference to that in the documentation.

You should have some files beginning with libgssapi.* in your 
Plugin-Directory. Delete them.