[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: allow bind_v2 not working?

--On Tuesday, August 31, 2004 10:37 AM -0700 ray v <rayv5n@yahoo.com> wrote:

Hi All!

I've added "allow bind_v2" to my slapd.conf, then I
run the following command.

slapd -d -1

Watching the client connect and issue its DN for
authentication I see text message, "requested protocol
version not allowed". With ethereal I can see the
client does try to bind with version 2.

Is "allow bind_v2" correct?? what am I doing wrong?

allow bind_v2 is correct.

It worked for me in the 2.1 tree, and works for me in the 2.2 tree. Are you sure your client is trying LDAPv2 or LDAPv3? Maybe it is trying an LDAP v1 bind. Have you experimented using ldapsearch to specify protocol 2 and test from the command line, rather than the client, so you can control all the parameters?


-- Quanah Gibson-Mount Principal Software Developer ITSS/Shared Services Stanford University GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html