[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: BerkeleyDB version

Try setting your LD_LIBRARY_PATH variable as well.

Something apparantly changed in the configure script in the last couple of versions of openldap which causes it to no longer build on many systems the same way it used to build (WRT to finding Berkely) - There are dozens of messages in the mailing list in the past month or so, all referencing the same issue.

I have yet to see an answer, however, as to what actually changed (or was broken)


-----Original Message-----
From: owner-openldap-software@OpenLDAP.org [mailto:owner-openldap-software@OpenLDAP.org] On Behalf Of Keith Kiedrowski
Sent: Thursday, August 19, 2004 8:04 AM
To: 'Parvate,Girija'; 'OpenLDAP software list'
Subject: RE: BerkeleyDB version

I still get the same error
it is openldap version 2.2.13 and berkeleyDB 4.2.52

-----Original Message-----
From: Parvate,Girija [mailto:parvateg@oclc.org]
Sent: Wednesday, August 18, 2004 1:49 PM
To: 'OpenLDAP software list'
Subject: RE: BerkeleyDB version

export CPPFLAGS="-I/path-to-your-install-BerkeleyDB/include"
export LDFLAGS="-L/path-to-your-install-BerkeleyDB/lib"

-----Original Message-----
From: Quanah Gibson-Mount [mailto:quanah@stanford.edu]
Sent: Wednesday, August 18, 2004 1:35 PM
To: Keith Kiedrowski; 'OpenLDAP-software@OpenLDAP.org'
Subject: Re: BerkeleyDB version

--On Wednesday, August 18, 2004 1:16 PM -0400 Keith Kiedrowski 
<kkiedrowski@dimarcogroup.com> wrote:

> I am running slackware 10
> when I run the ./configure I get and error that the Berkeley DB version is
> incompatible. I went and downloaded and installed the latest version of
> the Berkeley DB and still get this error.

What version of OpenLDAP?  Are you sure that OpenLDAP is picking up the 
version of BDB you installed, and not a version that is installed elsewhere 
on the system?


Quanah Gibson-Mount
Principal Software Developer
ITSS/Shared Services
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html