[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: TLS not supported

just do
*) apt-get source slapd
*) cd openldap2-x.y.z
*) then edit debian/rules  and change --without-tls to --with-tls
*) then 'dpkg-buildpackage'
*) install those deb-s and set them to hold.
   make some file where are lines in form
   <package name> hold

  like so:

      slapd hold
      ldap-utils hold
      libldap2 hold

then command 'dpkg --set-selections | cat foobar.txt'

note that when theres upgrade for thost packages apt-get wont overinstall
those. Then you must download new source, rebuild it and install it.

> If I rebuild OpenLDAP entirely this should also rebuild SLAPD or not? Or
> do
> you recommend leaving all as is and only rebuilding SLAPD. I am running
> Debian sarge