[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Showing ALL attribute values && ACI's (ITS#3215)

>>>>> "Pierangelo" == Pierangelo Masarati <ando@sys-net.it> writes:

    >> Quoting "Pierangelo Masarati" <ando@sys-net.it>:
    >>> I believe ACIs have never been tested after adding ACL
    >>> caching...  Can you provide a significant portion of your LDIF
    >>> and your slapd.conf, so that I can test it?
    >>  The included tar ball contains my slapd.conf, the ACL file and
    >> a LDIF dump. It's naturally not even CLOSE to my exact usage,
    >> but it will show the problem non the less...
    >> The password for the 'uid=turbo,ou=People,o=Swe.Net AB,c=SE' is
    >> 'turbo'. The problem is there in both GSSAPI and SIMPLE
    >> binds...

    Pierangelo> I have committed a quick fix to HEAD for this problem;
    Pierangelo> essentially, I disabled ACL caching for ACIs.  Please
    Pierangelo> report if it works for you.  In 2.2, all you need to
    Pierangelo> do is comment out the two occurrences of
    Pierangelo> ACL_RECORD_VALUE_STATE within ACI related code in
    Pierangelo> servers/slapd/acl.c (see attached patch).  Please
    Pierangelo> report if it works by means of the ITS.

I tried to use the ITS system for feedback. But I just couldn't find
the login page!

The patch worked, even though it sounds like this isn't THE fix - caching
is (almost) always a good thing (speed wise anyway) :). Thanx for the
quick fix... Now I can put 2.2 on the next live server...