[Date Prev][Date Next] [Chronological] [Thread] [Top]

Things are clearer now; slapd is running

Hi list!

Thanks for your replies!
Yes, I know this list is not really the place for install guidelines, but 
which one is right? Unfortunately it is not very easy to get everything ok 
with the tarballs.
However, I'll try again with your hints.

>Yes, using 2.2.2beta is a waste of time.  Get 2.2.13 or later.

Right, very odd. I'll kick that.

>You should start by downloading, applying patches, and then building the 
>latest Berkeley DB.

I did that.

>On my system, it looks like this:
>export LDFLAGS="-L/usr/local/BerkeleyDB.4.2/lib 
>export CPPFLAGS="-I/usr/local/BerkeleyDB.4.2/include"

Wow, that's it! After a lot of google-ing I found those flags as mentioned, 
but it didn't work. Thanx!

>Please refresh your FreeBSD ports repository via 

Yes, I thought about CVS as well, but I can't get thru the firewall. I don't 
know where the problem is; it just doesn't work. However, compilation was all 
right and I can finally try to actually use the software!

make test was successfull; the last two lines were:
run configure with --enable-hdb
run configure with --enable-ldbm

Is that important? What does it stand for? Some databases I guess.

Right, for the moment I'm happy. I was able to build a structure and browse it 
with gq (latest I think). By the way, this client is rather buggy.

Kind regards,