[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: [SPAM:#] Re: failed with ldapsearch with GSSAPI - Please helpppppppppp

--On Thursday, June 03, 2004 8:48 AM +0800 The Shell <samwun@hgcbroadband.com> wrote:

Quanah Gibson-Mount wrote:

--On Wednesday, June 02, 2004 11:00 PM +0800 The Shell
<samwun@hgcbroadband.com> wrote:

Here is more info with ldapsearch:

Sending more and more output isn't going to give any enlightenment on
the issue.

You didn't build cyrus-sasl correctly, from appearances, or you didn't
build a K5 library for it to link against.  Either way, you have no
GSSAPI support in your SASL implementation.  You need to rebuild
cyrus-sasl, and you may have to build a set of K5 libraries.


I found that cyrus-sasl-2.1.18 has a compliation option for krb4, but not krb5. Is that mean I need to downgrade my Kerberos version to 4?

No. You need to compile Cyrus-SASL with the --enable-gssapi option.




Quanah Gibson-Mount
Principal Software Developer
ITSS/TSS/Computing Systems
ITSS/TSS/Infrastructure Operations
Stanford University
GnuPG Public Key: http://www.stanford.edu/~quanah/pgp.html