[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Slurpd can't start...

Port 636 is the default LDAPS (LDAP over SSL) port. If you want slurpd to
use SSL,you must not specify TLS in the replica configuration.
So you can use any one of the following

replica host=apollo.fe.up.pt:636
 replica uri=ldaps://apollo.fe.up.pt

----- Original Message -----
From: "Jorge Ruão" <jruao@fe.up.pt>
To: "OpenLDAP Mail List" <openldap-software@OpenLDAP.org>
Sent: Wednesday, May 12, 2004 3:47 PM
Subject: Slurpd can't start...

> Hi,
> I'm working with OpenLDAP 2.2.11 now in a Slackware 9.1 machine.
> I've set the replica lines in slapd.conf with an uri as suggested. It's
> done like:
> _______________________________________________________
> backend         bdb
> database        bdb
> suffix          "dc=fe,dc=up,dc=pt"
> rootdn          "cn=admin,dc=fe,dc=up,dc=pt"
> rootpw          {CRYPT}...
> readonly        off
> directory       /usr/local/var/openldap-data
> replica uri=ldaps://apollo.fe.up.pt:636
>         binddn="uid=updatedn,ou=admins,dc=fe,dc=up,dc=pt"
>         bindmethod=simple credentials=secret
> replogfile      /etc/openldap/master-slapd.replog
> _______________________________________________________
> But every time I start SLURPD i'm still getting the error:
> Error: parse_replica_line: unknown keyword
> Error: Malformed "replica" line in slapd config file, line 78
> Warning: failed to add replica "(null):0 - ignoring replica
> Warning: unknown replica found in replication log
> Warning: unknown replica apollo.fe.up.pt:636 found in replication log
> Warning: unknown replica apollo.fe.up.pt:389 found in replication log
> I need to use URI because i'm working with ssl through port 636, but if
> i use HOST instead of URI i'm not getting this parse error....
> Any help would be gratefull, thanks
> Jorge Ruão