[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: modify dn while replication

tor, 04.03.2004 kl. 16.19 skrev jehan.procaccia:

>         liblber.so.2 is needed by (installed) php-ldap-4.2.2-18.3
>         liblber.so.2 is needed by (installed) autofs-3.1.7-36
>         liblber.so.2 is needed by (installed) postfix-2.0.11-5
>         liblber.so.2 is needed by (installed) nss_ldap-202-5
> etc ....

This is standard RH 9 and upwards (RHEL3, RHAS3) Openldap 2.0.27 client
library stuff. You *have* to keep it for the above dependencies.

> I noticed that openldap 2.2.6 provides :
> $ rpm -qpli openldap-2.2.6-1.i386.rpm | grep liblber
> /usr/lib/liblber.so.199
> /usr/lib/liblber.so.199.3.4

These are indeed the 2.2.6 versions of the above.

> I'am a bit lost in liblber.so versions here . Is my present openldap 
> 2.1.25 liblber.so.2 older or newer than the one provided by openldap 
> 2.2.6: /usr/lib/liblber.so.199 ?

Quanah remarked on the fact that the version numbers seem to be
illogical, after installing 2.2.5/6. 2.1.25 has liblber.so.2 linked to

What you seem to have done, is to try and unlink the original /usr/lib/
symlink to the 2.0.27 liblber and relink it with the new 2.2.6 liblber,
since both are in the same directory. Make some other directory and use
that ;) In fact, you should use a completely different prefix for the
whole new install.

I get round this by keeping all my 2.0.27 libs in /usr/lib, thus
preserving existing dependencies, and all my 2.2.6 libs in
/usr/local/lib. I thus have 2 liblber.so.2's, the original in /usr/lib
and the new one in /usr/local/lib.

>  Will I brake dependances if I rpm 
> --force my new openldap-2.2.6 packages ?

*YES* Do NOT do that.

That is why I insist on installing - almost, but not all -
source-compiled programs that could conflict with OS distro originals to
/usr/local. Solaris and UnixWare (used at any rate to) use /opt.



mail: billy - at - billy.demon.nl