[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: OpenLdap test fails

I have the same problem
And I use this configure
CPPFLAGS="-I/usr/include/openssl -I/usr/lib/sasl2 -I/usr/kerberos/include

CFLAGS="-I/usr/include/openssl -I/usr/lib/sasl2 -I/usr/kerberos/include
export CFLAGS
echo $CFLAGS

LDFLAGS="-L/usr/include/openssl -L/usr/lib/sasl2 -L/usr/kerberos/lib
-L/usr/local/BerkeleyDB.4.2/lib "
export LDFLAGS


#--with-dblib=/usr/local/BerkeleyDB.4.2/lib \
./configure     --with-slapd \
                --with-slurpd \
                --without-ldapd \
                --with-threads=posix \
                --enable-static \
                --enable-local \
                --enable-cldap \
                --disable-rlookups \
                --with-tls \
                --with-cyrus-sasl \
                --enable-wrappers \
                --enable-bdb \
                --enable-ldbm \
                --enable-multimaster \
		    --enable-passwd \
                --enable-crypt \
                --enable-spasswd \
                --enable-kpasswd \
                --enable-static \
                --enable-shared \

In config.log, there are many failed. For example
- /usr/bin/ld: cannot find -ldld
- indefined dlopen
- /usr/bin/ld: cannot find -lbe
- /usr/bin/ld: cannot find -ls
- /usr/bin/ld: cannot find -ldir
I have binutils-2.13.90 and autoconf-2.57-3. It's possible that the problem
is here?

-----Original Message-----
From: owner-openldap-software@OpenLDAP.org
[mailto:owner-openldap-software@OpenLDAP.org] On Behalf Of Voglmaier,
Reinhard Erich
Sent: martedì 27 gennaio 2004 13.33
To: 'sh302@lycos.com'; openldap-software@OpenLDAP.org
Subject: RE: OpenLdap test fails

This happens when the slapd daemon fails to start. One reason could be that
you used libraries which are located in "non standard" locations. Declare
such locations with "LD_LIBRARY_PATH" to fix this.

-----Original Message-----
From: S D [mailto:sh302@lycos.com] 
Sent: martedì 27 gennaio 2004 2.52
To: openldap-software@OpenLDAP.org
Subject: OpenLdap test fails

Hi, I have a solaris machine, the openldap compile have
been successful (configure, make depend, make) but the
"make test" fails.

$ ./configure --with-cyrus-sasl --with-bdb --with-tls
$ make depend
$ make
$ make test
make[1]: Entering directory `/src/openldap-2.1.25/tests'
ln: cannot create ./data: File exists
make[1]: [test-bdb] Error 2 (ignored)
ln: cannot create ./schema: File exists
make[1]: [test-bdb] Error 2 (ignored)
Initiating LDAP tests for BDB...
>>>>> Executing all LDAP tests...
>>>>> Test Directory: .
>>>>> Backend: bdb
>>>>> Starting test000-rootdse ...
running defines.sh
Datadir is ./data
Cleaning up in ./test-db...
Starting slapd on TCP/IP port 9009...
Using ldapsearch to retrieve the root DSE...
Waiting 5 seconds for slapd to start...
Waiting 5 seconds for slapd to start...
Waiting 5 seconds for slapd to start...
./scripts/test000-rootdse: kill: no such process
ldap_bind: Can't contact LDAP server (81)
>>>>> Test failed
>>>>> ./scripts/test000-rootdse failed (exit 1)
make[1]: *** [test-bdb] Error 1


Get advanced SPAM filtering on Webmail or POP Mail ... Get Lycos Mail!