[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: ldapadd requires confidentiality

tir, 20.01.2004 kl. 14.45 skrev "Frank Hoffsümmer":

> hello, i am evaluating openldap 2.1.25 and 2.2.4 in conjunction with bdb
> 4.2.25 on our solaris 8 machine.
> everything compiles and installs fine, after starting slapd, i want to add
> some entries to the server using 
> ldapadd (I used slappasswd to set the password in slapd.conf). Here is what
> follows
> bin/ldapadd -x -D 'cn=manager,dc=svt,dc=se' -W -f top.ldif 
> Enter LDAP Password: 
> ldap_bind: Confidentiality required (13)

"Confidentiality required" means you've told slapd to demand TLS in
slapd.conf: "security tls=1". So add '-Z ' onto the ldapadd command.
Mind you, you'd better have Openssl or your Sun equivalent linked into
your Openldap compile.


mail: billy - at - billy.demon.nl