[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: Postfix 2.0.16 CRAM/DIGEST-MD5 SMTP AUTH

Igor Brezac wrote:

The ldapdb auxprop plugin has to use PLAIN and DIGEST-MD5, however Mozilla
1.4 can use CRAM-MD5 or any other mech offered by the imap (?) server.

Mozilla ---CRAM-MD5---> imapd --> ldapdb ---DIGEST-MD5---> slapd

Yuk!! Mozilla Messenger's brain-dead enough as it is. ldapdb (2.1.22) works o.k., even with Openldap 2.1.23 and I use that for CRAM smtp AUTH direct to Postfix 2.0.16 snapshot. Messenger insists on CRAM if it's advertised.

The 2.1.23 ldapdb auxprop doesn't allow CRAM, though (insists on SASL proxy authorization). I'm happy though, I'm rid of the SASL 2.1.13 bugs in a very elegant way (thanks Howard :)


Tony Earnshaw

Once the camel's head has entered your tent,
it's very difficult to stop the rest of the
animal from following it

Mail: billy-at-billy.demon.nl