[Date Prev][Date Next] [Chronological] [Thread] [Top]

I have no name!@hostname

Hello everyone,

I recently upgraded some packages on my debian box, at first look
everything looked ok, however I've now seen some odd problems.

Firstly, and directly related to the others is for some reason, although
I can login,  when I do so I get a prompt like this

I have no name!@rauru
Interestingly, I can't scp anything
for example
I have no name!@rauru:/var/www/timesheet$ scp add.php ruto:
unknown user 1039

Also getent passwd jhenkel doesn't fetch anything unless I run it as

As shown here:

I have no name!@rauru:/var/www/timesheet$ getent  passwd jhenkel
I have no name!@rauru:/var/www/timesheet$ sudo getent passwd jhenkel
jhenkel:x:1039:1000:Jayson Henkel:/home/jhenkel:/bin/bash

Can someone explain what all this behaviour means and how to correct it?


Jayson D. Henkel
Systems Manager

(Tel:  +1 (780) 440-4434)
(Fax:  +1 (780) 440-1951)
(Cell: +1 (780) 886-8941)
(E-Mail: jhenkel@sterlingcrane.ca)

Sterling Crane
P.O. Box 8610. Station South
Edmonton, Alberta
Canada. T6E 6R2

The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential and/or privileged
material. If you are not the intended recipient of this message you are
hereby notified that any use, review, retransmission ,
dissemination,distribution, reproduction or any action taken in reliance
upon this message is prohibited. If you received this in error, please
contact the sender and delete the material from any computer. Any views
expressed in this message are those of the individual sender and may not
necessarily reflect the views of the company.