[Date Prev][Date Next] [Chronological] [Thread] [Top]

Compiling Samba against OpenLDAP 2.0.27

Hi, I'm having some problems when compiling Samba against the OpenLDAP
2.0.27 shared libraries, I'm trying to compile Samba 3.0beta2 with LDAP
support but it can't find the ldap libraries for some reason. I'm not a
programmer so I don't understand how all these autoconf/automake script
works but I did some research and it seems that Samba is testing to see
if the ldap_init function is there and automake/autoconf or whatever is
compiling a small test program with -lldap. I did a small C file that
calls this function and tried to compile it with GCC.

I tried with just -lldap at first but I got a lot of undefined
references error, so I tried with -llber and I got only 2 undefined
references so I added -lresolv (since I recalled I had to add this in
the Makefile to compile Samba 2.2.X against OpenLDAP) and it worked. So
I'm thinking that the configure script in Samba doesn't link against all
those libraries so that's why it's saying that it doesn't find the LDAP

What are my options here? Is this an OpenLDAP issue or a Samba issue?


Jean-Rene Cormier