[Date Prev][Date Next] [Chronological] [Thread] [Top]

Re: cyrus sasl solaris 9

I believe that your SASL version is too new. See line 14834 ff of
configure in version 2.0.27, or if you have a different version of
2.0.x, search in configure for SASL_VERSION. I _think_ support for SASL
2.1.x was added in OpenLDAP 2.1.x. You can install both versions on the
same machine, though if you _really_ need it. They lived together on one
of my machines happily for several months.

hth. Mike.

>>> ineves <ineves@iportalmais.pt> 04/01/03 10:28am >>>
Hello, i have compiled openldap 2.1.* sucefully in solaris 9, and it
works great, but i need openldap 2.0.* version, soo, when i try to
compile, i never get ./configure sucefully, dont understand why, i have
done exacly like in 2.1.*, and it dont works...

it stop's here...

checking for sasl.h... yes
checking for sasl_client_init in -lsasl... no
configure: error: Could not locate Cyrus SASL

I have:

LDFLAGS="-L/opt/cyrus-sasl/lib/sasl2 -L/opt/cyrus-sasl/lib
-L/opt/sfw/lib/ -L/usr/local/lib -L/usr/lib"

And it dont give me that error, what library is he looking for?
when i try gcc -lsasl , it says dont find the lybrary too, but openldap
2.1.* compiles great, but i need 2.0.*, some one know how to help me?