[Date Prev][Date Next] [Chronological] [Thread] [Top]

Install problems

I have been unable to install for the last 6 hours: Here is my

Redhat 7.0 2.2.19
libtool 1.4.3
gdbm 1.8.3 in /usr/local/lib
openssl 0.9.7
Berkeley DB 4.1 in /usr/local/BerkeleyDB.4.1/

trying to install OpenLDAP 2.1.12

At first I had trouble with not finding the Berkeley DB so in installed
latest. Then came openssl support I had to install. Then libtool and gdbm i

Most of the make errors left when I did these things, including making

so heres my commands:

$> env CPPFLAGS="-I/usr/local/BerkeleyDB.4.1/include"
LDFLAGS="-L/usr/local/BerkeleyDB.4.1/lib" ./configure
which goes well.
$> make depend
goes well
$> make
this has never gone well. The latest error is this, and has been so for some

./.libs/libldap.a(tls.o): In function `tls_report_error':
/home/luis/openldap-2.1.12/libraries/libldap/tls.c:1544: undefined reference

while linking apitest

Has anyone else seen this problem? I haven't seen anything particular about
this on other groups or the LDAP faq.

Please advise if you have some thoughts on it!! Thanks so much!!


Luis Andrei Cobo
Download My Resume: http://www.tarso.net/business/resume_mailer.asp