[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: BerkeleyDB help

Current releases of OpenLDAP 2 only support up to version 4.0.14 of Berkeley
DB. You should not be using BDB 4.1.17 since it was only a test release. The
official BDB 4.1 release is version 4.1.24 which just became available at
www.sleepycat.com. This version will be supported (and highly recommended) in
OpenLDAP 2.1.5. In particular, the fix for ITS#2040 is in BDB 4.1.24.

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support

-----Original Message-----
From: owner-openldap-software@OpenLDAP.org
[mailto:owner-openldap-software@OpenLDAP.org]On Behalf Of Larsson Mikael

I have installed Berkeley 4.1.17  and I  have also tried version 4.0.14....
But the openldap-configure always says...

checking for Berkeley DB Link (default).. no
checking for Berkeley DB Link (-ldb4).. no
checking for Berkeley DB Link (-ldb-4).. no
checking for Berkeley DB Link (-ldb).. yes
checking for Berkeley DB thread support.. yes
checking for Berkeley DB version for BDB backend... no
configure: error: BDB: BerkeleyDB version incompatible

The openldap-FAQ says....
You can force configure to use a specific database manager using
the --with-ldbm-api option.
To specify use of Sleepycat BerkeleyDB (release 2.x or greater), use:
./configure --with-ldbm-api=berkeley

What I´m a doing wrong ?

Mikael Larsson