[Date Prev][Date Next] [Chronological] [Thread] [Top]

RE: memory leak

> -----Original Message-----
> From: owner-openldap-software@OpenLDAP.org
> [mailto:owner-openldap-software@OpenLDAP.org]On Behalf Of Alicia
> Rioperez

> Hello everybody,
> I'm developing a ldap application and I have noticed that my program
> suffers a memory leak.
> I'm using the default openldap libraries installed with redhat linux 7.2
> (I think the release is 2.0.11). By the way, how can I check the release
> of slapd if it's already installed and there are no sources?

Look for LDAP_VENDOR_VERSION in include/ldap.h. It will be defined to 20011
if you're actually using 2.0.11. You should upgrade to a current version as
that release is quite old, and there have been memory leaks in the library
that were fixed between 2.0.11 and the current 2.0.25.

  -- Howard Chu
  Chief Architect, Symas Corp.       Director, Highland Sun
  http://www.symas.com               http://highlandsun.com/hyc
  Symas: Premier OpenSource Development and Support