[Date Prev][Date Next] [Chronological] [Thread] [Top]

[long][help] OpenLDAP as an NT service


Here's a blocking problem I'm facing, trying to make my own build of OpenLDAP for Win32.

Here are the packages I'm using:
        * OpenLDAP 2.0.25
        * Berkeley DB 4.0.14
        * Cyrus SASL 1.5.27
        * hs_regex_dist
        * When my problem is be solved (I hope), I'll add TLS support with OpenSSL.

After having built all my packages (Win32/Release), OpenLDAP works fine as a standalone

I encounter what has become my nightmare when I use it as a NT4/2000 service:
The service installation works fine.
Correct configuration values are put in the registry (Url, ConfigFile, DebugLevel).

But when I start the service, here is what happens after 20/30 secs:

* from the services/MMC:
        Error 1053: The service did not respond to the start or control request in a
        timely fashion.

* from a command prompt:
        The Service is not responding to the Control Function
        More Help is Available by Typing NET HELPMSG 2186 

* in the event log:
        Event ID: 7000
        Source: Service Control Manager
        Description: The Service OpenLDAP Directory Service failed to start due to the
        following error: The service did not respond to the start or control request in
        a timely fashion.

        Event ID: 7009
        Source: Service Control Manager
        Description: Timeout (30000 milliseconds) waiting for the Service name service
        to connect.
        OpenLDAP Directory Service

I've tried running the service as an user, LocalSystem, LocalSystem with desktop
interaction. No success.

Anyone willing to help me will be greatly welcome because I really don't understand what
happens. Moreover, I had successfully build a Win32 port without such
a problem several days ago. Unfortunately, I can't manage to do it again, even with my
initial build environment.

Thanks in advance for any clue/hint. I really need to solve that problem.

Best regards,

Jacques-Etienne Rahon